USB Patch: 2 days later

by editor @ AppleTVHacks.net on July 29, 2007


We are aware that the USB Patch released on Friday night was pretty restrictive on the requirements:  Intel-Mac, OS X files, Apple TV Software 1.0, etc.

Now that the source code is out in the wild,  we would like the community to investigate these issues and submit improvements over the existing code.

We feel that the highest priority is to make the patch work with Apple TV software 1.1.  Reverting back your Apple TV software to the previous version is just a step backward.  One shouldn’t have to be forced to do this.

Next priority is to make the install script work on other environments:  Windows, PPC OS X, etc. Correct me if I’m wrong but if all of compilation takes place on the Apple TV, (which runs the Intel version of OS X) then there shouldn’t be any restrictions on the computer that remotes into it, right?  Or you can just tell me that I’m full of it.

Of course, the ultimate goal is to wrap the geeky stuff in a nice GUI, then we’ll all be happy.  Volunteers?

So what are you waiting for?  Help us out.  All lines are opened, operators are standing by.

Previous post:

Next post: